CircleCI UI Loading & build triggering issues

Incident Report for CircleCI

Resolved

The incident has now been resolved. Thank you for your understanding and patience while our engineers investigated and mitigated the issue.
Posted Apr 04, 2025 - 02:11 UTC

Monitoring

A fix has been implemented, and we are currently monitoring the system to ensure everything is functioning as expected. Thank you for your patience.
Posted Apr 04, 2025 - 01:51 UTC

Update

We are investigating intermittent issues triggering pipelines or sending status updates.
Posted Apr 04, 2025 - 01:34 UTC

Investigating

We are investigating intermittent issues with loading the CircleCI UI.
Posted Apr 04, 2025 - 01:17 UTC
This incident affected: Pipelines & Workflows, CircleCI UI, and Notifications & Status Updates.