Customers may experience delays in UI updates

Incident Report for CircleCI

Resolved

The incident impacting pipeline data in the UI has now been resolved. We thank you for your patience while our engineers worked on reducing the delays.
Posted Sep 15, 2026 - 17:02 UTC

Identified

We are starting to see some recovery.
Posted Sep 15, 2026 - 15:14 UTC

Investigating

We are currently seeing a delay in pipeline data surfacing in the UI.
Posted Sep 15, 2026 - 14:42 UTC
This incident affected: CircleCI UI.