We've seen no further impact to queue times and everything has returned to normal. We appreciate your patience while we worked to resolve and monitor this issue.
Posted Sep 04, 2026 - 16:55 UTC
Monitoring
Our Mac infrastructure provider has applied a fix to this networking issue and we're seeing queue times return to normal. We're going to continue keeping an eye on things for a little while longer. We'll update again shortly.
Posted Sep 04, 2026 - 16:19 UTC
Identified
We've identified the networking issue with our Mac infrastructure provider, and are working with them to resolve the issue. We're starting to see some recovery, but we expect customers may still see some queueing. We'll update again shortly.
Posted Sep 04, 2026 - 15:43 UTC
Investigating
We have detected network issues affecting our Mac infrastructure. We're investigating and will provide updates shortly. Customers may experience queuing during this time.