M2Pro.Large resource class jobs delayed

Incident Report for CircleCI

Resolved

Jobs should now be running normally. Thank you for waiting whilst we addressed this issue.
Posted Sep 01, 2025 - 17:20 UTC

Identified

We have identified an issue with our process for distributing machine images to our Mac fleet affecting M2Pro Large. We are currently working on remediating this but it will take some time to do so. Wait times should continue to be around 8 minutes until this is resolved. Thank you for your continued patience.

All other Mac resource classes remain unaffected.
Posted Sep 01, 2025 - 14:28 UTC

Investigating

We are currently investigating alerts which indicate that M2Pro Large resources are delayed starting. All jobs will run but customers may experience wait times of 8 to 10 minutes to get machines. Thank you for your patience while we investigate.
Posted Sep 01, 2025 - 14:00 UTC
This incident affected: macOS Jobs.