Customers may experience delays in UI updates

Incident Report for CircleCI

Resolved

This incident has been resolved.
Posted Sep 16, 2026 - 19:30 UTC

Monitoring

All pipeline data is now available as normal. We will continue to monitor recovery.
Posted Sep 16, 2026 - 18:22 UTC

Update

Pipeline data is now available as normal, with the exception of test results, which may still be delayed. We are continuing to work on this, thank you for your patience.
Posted Sep 16, 2026 - 17:34 UTC

Identified

We have identified the issue and are working on a remediation. Thank you for your patience.
Posted Sep 16, 2026 - 15:29 UTC

Investigating

We are investigating a delay in pipeline data becoming available. Pipelines are still running, but data about them may be delayed in the UI or API.
Posted Sep 16, 2026 - 14:55 UTC
This incident affected: CircleCI API and CircleCI UI.